Get in touch
Back
Maintenance

Planned Maintenance

Completed 21 Feb at 01:00pm CET.

hub.farmerconnect.com api.farmerconnect.com
Completed

Maintenance completed

Posted 21 Feb at 01:00pm CET.
Started

We'll be releasing an upgrade related to the user roles on ConnectHub, hence users might be required to log out & in again for continued solution use.

Posted 21 Feb at 11:00am CET.