Get in touch
Back
Maintenance

Planned Maintenance

Completed 19 Jul at 08:00pm CEST.

hub.farmerconnect.com api.farmerconnect.com farmerid.com thankmyfarmer.com
Completed

Maintenance completed

Posted 19 Jul at 08:00pm CEST.
Started

Service upgrade.

Posted 19 Jul at 12:00pm CEST.