Get in touch
Back
Resolved

Map issues

Started 30 Apr at 10:15am CEST.

hub.farmerconnect.com thankmyfarmer.com
Created

We're currently experiencing an issue with the maps across our platform.

Our engineers are working hard to resolve the problem and we apologize for the inconvenience!

Posted 30 Apr at 10:15am CEST.