Get in touch
Back
Maintenance

Planned Maintenance

Completed 1 Feb at 10:00am CET.

hub.farmerconnect.com api.farmerconnect.com
Completed

Maintenance completed

Posted 1 Feb at 10:00am CET.
Started

A system update will be carried out in the morning for the ConnectHub and API services, potentially causing a small interruption of service.

Posted 1 Feb at 09:00am CET.