Get in touch
Back
Maintenance

Planned Maintenance

Completed 8 Feb at 06:00pm CET.

hub.farmerconnect.com api.farmerconnect.com farmerid.com thankmyfarmer.com
Completed

Maintenance completed

Posted 8 Feb at 06:00pm CET.
Started

A system update will be carried out in the afternoon, potentially causing a small interruption of service.

Posted 8 Feb at 01:00pm CET.