Back
Maintenance
Planned Maintenance
Completed 13 Aug at 11:59pm CEST.
hub.farmerconnect.com
api.farmerconnect.com
farmerid.com
thankmyfarmer.com
Completed
Maintenance completed
Posted
13 Aug at 11:59pm CEST.
Started
Important third-party service upgrade.
Posted
13 Aug at 07:00pm CEST.