Back
Maintenance
Planned Maintenance
Completed 15 Aug at 05:00am CEST.
hub.farmerconnect.com
api.farmerconnect.com
farmerid.com
thankmyfarmer.com
Completed
Maintenance completed
Posted
15 Aug at 05:00am CEST.
Started
Important third-party service upgrade.
Posted
14 Aug at 03:00pm CEST.